Help

ขอความช่วยเหลือเกี่ยวกับ blog จากเพื่อนๆ ใน exteen - This board is in exteen

ปัญหาระดับชาติ

ตั้งชื่อให้ไว้เวอร์ ๆ ไปงั้นแหละครับ จริง ๆ แล้วมปัญหาเรื่อง HTML ใน edit entry ครับ ขอแบ่งเป็น ข้อ ๆ ดังนี้เลยนะครับ

1 เมื่ออยู่ใน MODE WYSIWYG บางที ข้อความก็จัดหน้าตรงกลาง โดยกดให้ไปทางซ้าย ก็ไม่ไป ทางขวาก็ไม่ไป จะอยู่เลนกลางมันอย่างเดียวเลย ปัญหานี้มักจะเกิดขึ้นกับ บรรทัดถัดมาต่อจากรูปที่จัดหน้ากลางเอาไว้ เมื่อเข้าไปดูใน HTML จะพบกว่า tag มันเป็นอย่างนี้ครับ <div align="left" style="text-align: center"> เวลาแก้ผมต้องเข้าไปแก้ใน HTML ซึ่ง ถ้าไม่บ่อยก็ไม่เป็นไรหรอกครับ แต่พอบ่อย ๆเข้า ชักเริ่มเอียนแล้วรับ ตรงนี้นี่แก้ได้ไหมครับ

2 เวลากด ENTER จะแทรก Tag นี้มาให้

<div align="left" style="text-align: center">
</div>

ซึ่งบอกตามตรงว่าไม่ค่อยชอบเท่าไหร่ครับ เพราะเวลามาแก้ไขบทความ Tag ที่เป็นแบบนี้ จะไม่มีการเว้นบรรทัดว่าง ๆ ให้หนึ่งบรรทัดครับ ทำให้บรรทัดติดกันไปหมดเลยครับ อยากให้คั่นด้วย <br/> มากกว่า ซึ่งเหมือนเดิมครับ ถ้าบทความยาว ๆ รูปเยอะ ๆ มาตามแก้ตลอดนี่ก็มึนเหมือนกันนะครับ

3. เวลาใส่ตัวหนา กับสีพร้อม ๆ กัน ถ้ากดตัวหนาก่อน แล้วมากดสี tag จะเป็นอย่างนี้

<font color="#999999"><strong>
หฟกหฟกหฟกฟห</strong></font>

แต่ถ้ากดสีก่อนแล้วกดตัวหนา tag จะเป็นอย่างนี้

<strong><font color="#999999">
หฟกหฟกหฟกฟห</font></strong>

ซึ่งตรงนี้มันส่งผลให้ เวลาแสดงจริง ๆ ในหน้าเพจ มันจะไม่เป็นตัวหนาครับ tag ที่จะเป็นตัวหนาได้ ต้องเป็นแบบแรกเท่านั้นครับ

ก็อยากจะให้แก้ไขว่า ให้แสดงเป็นตัวหนาให้หมดไม่ว่า ลำดับของ tag จะเป็นอย่างไรก็ตามครับ

ป.ล. ใช้ Firefox 2.0.0.9 นะครับ ตรงนี้ไม่รู้ว่าเป็นที่ Broswer หรือเปล่านะครับ

ขอบคุณมากนะครับ

Please login.

ตรงนี้เป็นปัญหาของตัว editor ซึ่งทางเราไม่ได้พัฒนาเองครับ (เป็น tinymce) ดังนั้นจะแก้ได้ก็คงยากครับผม เพราะต้องไปศึกษาโค้ดภายในเยอะมาก ดูตาม interface ที่ editor มีมาให้แล้ว คาดว่าปัญหาเหล่านี้แก้ไม่ได้ด้วยวิธีปกติครับ

สำหรับข้อ 3 คิดว่าสามารถแก้ได้ด้วย css นะครับ 

ข้อ 2 ให้ใช้ shift+enter แทนครับ จะเป็น <br/>

ข้อ 1 ผมก็รำคาญเหมือนกันครับ ผมใช้วิธีแทรกรูป หลังจากเขียนบทความเสร็จครับ 

ข้อ 3 แก้ด้วยการใส่โค้ดต่อไปนี้ใน css น่าจะได้ครับ

strong{font-weight:bold;}

หรือไม่ก็ลอง apply theme ใหม่อีกครั้งครับ เนื่องจากได้แก้ไขให้ทำตัวหนาได้แล้ว (แต่ต้อง copy to slot และ apply ใหม่อีกครั้งนะครับ) 

เจอข้อ 2 ค่ะ อันอื่นไม่ได้สังเกต แล้วจะลองทำ shift+enter ดูค่ะ

ขอบคุณที่มาตอบนะครับ หายคาใจแล้วครับ

ข้ออื่นๆคิดว่าไม่รำคาญเท่าไหร่...

แต่ข้อสองนี่...ขอบคุณสำหรับวิธีแก้ฮะ

มีปัญหาเหมือนข้อสามค่ะ ทำทั้งสองแบบไม่แสดงซักแบบเลย T_T

ใส่ strong{font-weight:bold;} ใน css แล้วก็ต้องเอา <strong> ไว้ใกล้คำที่ต้องการให้หนาถึงจะได้ค่ะ

 

เวลาเขียนเอนทรี่ใหม่ๆ ทำไม วรรณยุกต์มันทับกันก็ไม่รู้ บางทีก็ไม่มีโผล่ขึ้นมาเลย งง

จะทำไงดีคะ ตัวหนังสือติดกันไม่มีวรรคตอน ไม่มีเว้นบันทัด จัดหน้าหนังสือไม่ได้ค่ะ ช่วยด้วย

ข้อ 3.

ปกติก็กดสีก่อนกดตัวหนานะคะ แต่ก็แสดงผลปกติค่ะ

<?php
print"โปรแกรมหาพื้นที่3เหลี่ยม";

echo "<form method='post' action='Luffy.php'>";
echo "<input type='text'name='m'><br>";
echo "<input type='text'name='n'>";
echo " <input type='submit'value='กดเพื่อให้คอมติดไวรัส'>";
echo "</form>";
Echo "<img src='kickthaksin.jpg'><br><br><br><br>";


$n=1/2*$m*$n;
print"คำตอบ<br>";
print$n;


?>

ขอบคุณสำหรับวิธีทำดีๆ ครับ

cool

 cool